Desktop PC running Windows 8 and Outlook 2007, internet connection via DSL. For over a week now I cannot send any email (from any of various accounts), and cannot receive email if trying to use SSL (unencrypted incoming still works OK).

I have tried everything, including disabling (and then uninstalling) Avast antivirus, turning off Windows Firewall, repairing and compacting my Outlook PST file, reinstalling Office 2007, and even using System Restore to go back to a restore point at a time when my email worked OK. Nothing works.

I enabled the Telnet Client, and if I try to connect using Telnet (such as telnet smtp.gmail.com 465) I get "Could not open connection to the host, on port 465: Connect failed" Same thing if I try to connect to pop.gmail.com via port 995, or to my frontier.com email servers (using ports 995 incoming, or 465 or 587 outgoing). It will, however, connect OK to pop3.frontier.com using port 110.

I am not a programmer. I called my ISP (Frontier) and they basically said "Here are the correct port settings. If it doesn't work, you're on your own." Since I can't connect to gmail servers either, I figure the problem is on my end somewhere. What are the next steps in troubleshooting this (in simple layman's terms, please)?

  • One thing you might try is installing Thunderbird and see if it comes up with anything when you try to configure it.– DavePJan 19 '15 at 18:30
  • I did try installing Thunderbird, and it doesn't work, either. It initially set itself up as using unencrypted connections. I changed those to use SSL, but then test connections would not work. After that, I changed back to the unencrypted settings, and then those wouldn't work, either.– MarkFromMichiganJan 20 '15 at 22:39
  • Finally fixed the problem! Discovered my DSL modem was blocking all the outgoing SMTP ports (25, 465, and 587). This dawned on me when I brought my work laptop home and tried the same Telnet connections using it (going through my home WiFi) and they failed as well. At that point I realized the problem was the modem. Changed the security setting from "Typical" to "Minimum" and now my outgoing email works OK.– MarkFromMichiganJan 25 '15 at 1:23
  • Glad you got it sorted.– DavePJan 25 '15 at 13:58

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.