I have just installed Windows 8.1 and I have noticed a mystery device being detected under Networks.

Here is a screenshot showing the device and its properties. It identifies itself as a Nexus 7 - a device I do not own:

enter image description here

When attempting to manually add the device through "Devices and Printers", the device shows up as seen in this image:

enter image description here

Attempting to add it results in "Windows doesn't have a network profile for this device".

This device has some interesting properties:

  1. I've noticed that the first three bytes of the MAC address (OUI) are the same as my computer (MOOGAMING), however the second three are different. I'm unsure of the significance of this.

  2. The device is showing up under a category of "Computers" as opposed to "Computer" like other computers do. Why would Windows categorize this device differently?

  3. It does not appear in the attached device list of my router and doesn't appear to have an IP address.

  4. It disappears and reappears in a seemingly random manor.

I've tried changing my SSID and the network key to no avail (I do not believe it is connecting through WIFI).

I am currently using a power-line adapter to connect my computer to the router downstairs. The computer has no WIFI or Bluetooth adapters.

I am going to try changing the Window's Workgroup, but I have no hopes for this. Ideally I would like to identify why it is detecting this device.

Any advice on how I can identify this device and prevent it from showing up is appreciated.

Edit 1

Created a shortcut to the device and then opened it in notepad. It contains the following information among others:

  • urn:schemas-wifialliance-org
  • device:WFADevice
  • Provider\Microsoft.Networking.WCN

Edit 2

Having searched further, I have discovered that the connection type of Microsoft.Networking.WCN is actually the "Windows Connect Now" feature.

I have disabled the Windows Connect Now service and also disabled WPS on my router. The device has since not reappeared (touch wood).

  • What's the make and model of the system you're installing Windows 8 on? Is this a new computer or one you've previously used (with a different OS)?– Ƭᴇcʜιᴇ007May 28 '14 at 17:41
  • It's a custom built PC. I previously used Windows 7 and the issue may have also been there but I had not noticed it.– MooMay 28 '14 at 17:42
  • 4
    It seems to be a common problem that occurs when two neighbours both use Powerline networking. The suggestions on the internet seem to be to change your Powerline security settings from the default.– James PMay 28 '14 at 18:04
  • 1
    Have you disabled network discovery? Because the device is on your network, its clearly a device, which is visible but not setup for file sharing. The reinstallation of your operating system won't solve this problem, because its not a problem, there is nothing strange about this device being on your network.– RamhoundMay 28 '14 at 18:40
  • 1
    You can always disable network discovery which is basically the problem. Your computer is configured to find other Windows machines on the network. Those machines have to be discoverable but they don't have to setup sharing of files. The security of your powerline network is a seperate problem, not entirely sure how to fix that, just know its seperate from this.– RamhoundMay 28 '14 at 19:02

What is the manufacturer of your router? What motherboard do you have?

The first 6 letters of a MAC represent the manufacturer.

This device is either a service offered by your router, possibly an integrated system in your motherboard or someone has managed to get on your network in which case I would block the MAC in the router. Judging from the device model I would assume the latter.

If you cannot control other devices entering your network I would change your connection type to public which changes a number of firewall and discovery settings.

  • The first 6 characters, not counting : or -– Cliff ArmstrongJul 14 '17 at 2:12
  • @CliffArmstrong I will assume you're correct :D, edited– AirCombatAug 7 '17 at 2:15

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.