I enabled the shell with this tutorial https://www.windowscentral.com/how-install-bash-shell-command-line-windows-10

But if I have a shell script named ca.sh in a project root directory, I still can't run inside the project root with http://superuser.com/ca.sh and error out with

'.' is not recognized as an internal or external command

Anything I can do to enable shell mode inside ConEmu?

http://superuser.com/ca.sh content:

#!/bin/shecho "Commit all with message: $1"git statusgit add *git commit -m "chore(): $1"git push origin master

I originally wrote something similar on MacOS and it runs well.

    Silly me! ConEmu already has the Bash task... and yes, I am noobie, so I actually confused Bash with Shell.... because my script is actually bash script.

    enter image description here

    Click into the list with the Green background white + button, you will see the Bash as an option, actually Shell too!

      Your Answer

       
      discard

      By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

      Not the answer you're looking for? Browse other questions tagged or ask your own question.