i have a Kali Linux 2.0 2017 64 bit ; what i discovered is that settings does not load anytime i press the setting option whenever i want to modify settings , all i get is just nothing. not even an error. i have tried to install the gnome-control-centre using apt; but i get this error:

olalekan@MW:~$ sudo apt-get install gnome-control-centerReading package lists... DoneBuilding dependency tree Reading state information... DoneSome packages could not be installed. This may mean that you haverequested an impossible situation or if you are using the unstabledistribution that some required packages have not yet been createdor been moved out of Incoming.The following information may help to resolve the situation:The following packages have unmet dependencies:gnome-control-center : Depends: libcanberra-gtk3-0 (>=0.25) but it is not going to be installedDepends: libcheese-gtk23 (>=3.4.0) but it is not going to be installedDepends: libcheese7 (>=3.0.1) but it is not going to be installedDepends: libclutter-1.0-0 (>=1.11.10) but it is not going to be installedDepends: libclutter-gtk-1.0-0 (>=0.91.8) but it is not going to be installedDepends: libcolord-gtk1 (>=0.1.24) but it is not going to be installedDepends: libgnome-bluetooth13 (>=3.12.0) but it is not going to be installedDepends: libgnome-desktop-3-10 (>=3.11.90) but it is not going to be installedDepends: libgoa-backend-1.0-1 (>=3.10.0) but it is not going to be installedDepends: libgrilo-0.2-1 (>=0.2.2) but it is not going to be installedDepends: libgtk-3-0 (>=3.13.7) but it is not going to be installedDepends: libnm-gtk0 (>=0.9.7.997) but it is not going to be installedDepends: libsoup2.4-1 (>=2.33.92) but it is not going to be installedDepends: gnome-settings-daemon (>=3.13.91) but it is not going to be installedDepends: gsettings-desktop-schemas (>=3.13.91) but it is not going to be installedRecommends: gnome-online-accounts but it is not going to be installedRecommends: gnome-user-guide but it is not going to be installedRecommends: gnome-user-share but it is not going to be installedRecommends: gkbd-capplet but it is not going to be installedRecommends: mousetweaks but it is not going to be installedRecommends: policykit-1-gnomeRecommends: rygel but it is not going to be installed orrygel-tracker but it is not going to be installedRecommends: system-config-printer (>=1.4) but it is not going to be installedRecommends: network-manager-gnome (>=0.9.8) but it is not going to be installedE: Unable to correct problems, you have held broken packages.

after getting this error i think if i try to install all the depending and required packages independently, but as i try to install them one by one , i discover ; they are layered dependencies that each of the packages specified required ; and in some ways , some of the libraries are installed but apt keep claiming they are not going to be installed. any help is appreciated... thanks.

share|improve this question
1 
This pretty sums up your problem: if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. Kali Linux isn't a stable distribution since it's based on Debian Testing, which is a rolling release. And rolling releases are as a matter of fact always breaking once in a while, no matter what people say about their strictly specific experience.– X.LINK2 days ago
   
so, what shall i do now ; or does this mean the os must be reinstalled– Olalekan Adebari2 days ago
1 
You shouldn't use Kali Linux as a daily driver, consider Debian or Ubuntu 16.04.1 (LTS). Why do you want to use Kali Linux in the first place ?– X.LINK2 days ago
   
i have been using it for almost three years now and i havent face this kind of error. i use it basically because it gives the required satisfaction i want. is there a way i can reinstall the gnome or something to solve the problem– Olalekan Adebari2 days ago
1 
In its current state, Debian Testing is still Alpha -so does Kali Linux-. If you really want to stay with Kali Linux, you'll have to wait for Debian Testing to get a proper gnome package. Besides, I'm still surprised that your Kali Linux install is still running; switching from 1.0.x to Sana then 2017.x isn't a peaceful path.– X.LINK2 days ago

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.