I just bought new laptop with AMD Radeon RX 550M card, installed fresh new Fedora 27 and everything was working properly.

But...

After update (dnf update) and restarting laptop my hdmi stopped working.I dind't install any drivers manually. Do you maybe have any suggestions what might gone wrong?I provide lspci and xrandr output:

lspci

00:00.0 Host bridge: Intel Corporation Device 5914 (rev 08)00:02.0 VGA compatible controller: Intel Corporation Device 5917 (rev 07)00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 (rev 21)00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #1 (rev f1)00:1c.4 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 (rev f1)00:1d.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #9 (rev f1)00:1d.1 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #10 (rev f1)00:1d.2 PCI bridge: Intel Corporation Device 9d1a (rev f1)00:1f.0 ISA bridge: Intel Corporation Device 9d4e (rev 21)00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)01:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Lexa PRO [Radeon RX 550] (rev c0)02:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller SM961/PM96103:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)04:00.0 Network controller: Intel Corporation Dual Band Wireless-AC 3165 Plus Bluetooth (rev 99)05:00.0 SD Host controller: O2 Micro, Inc. SD/MMC Card Reader Controller (rev 01)

xrandr -q

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192XWAYLAND0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 340mm x 190mm1920x1080 59.96*+

What might be worth to mention: I run bios in legacy support mode (not UEFI), graphic card is choosen to be discrete.

share|improve this question
1 
I noticed one strange thing: I enabled UMA only graphic card in bios, then dual screen started to work, but of course my Radeon card disappeared from lspci. Then I turned discrete again and now HDMI works again as before.– artixJan 13 at 17:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.