I have Vim 8.0 running on Arch Linux (last updated 3rd of January) and have installed the package powerline-fonts using pacman as well as vim-airline using Vundle. I have also set let g:airline_powerline_fonts=1 in ~/.vimrc. The problem is; there's a tiny gap to the right of the the arrow-like symbols on the right part of the status bar. As can be seen below, this damages the looks of Vim Airline. It does not affect the arrow-like symbols on the left part of the status bar (probably because the spacing is to the right). This seems like a bug to me?! Does anyone know a workaround?

Kind regards.

vim-airline spacing

EDIT: By the way, this is a nearly minimal .vimrc when using Vundle:

set nocompatiblefiletype offset rtp+=~/.vim/bundle/vundlecall vundle#begin()Plugin 'gmarik/vundle'Plugin 'vim-airline/vim-airline'call vundle#end()let g:airline_powerline_fonts=1
share|improve this question

For others encountering similar problems, some hints to how to make this work can be found in the following Github issue:

https://github.com/vim-airline/vim-airline/issues/1637

Notice that vim-airline with powerline fonts is very fragile in the sense that it depends on the exact font settings of your system. There is no attempt to avoid that.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.