I have a device on my network (I have tried disabling the firewall, turned off the local security settings in the router - everything I can think of) and it just refuses to speak.

No idea what to do!

1 - Router TL-WR841N - 192.168.0.1

2 - Desktop - 192.168.0.2 - The annoying one

3 - Laptop - 192.168.0.3

4 - Phone - 192.168.0.4


At first I thought it was the laptop and desktop refusing to speak to each-other.

But then I found out that desktop can communicate with all other devices fine (one way, from Desktop to the other devices) - but I have tried pinging the desktop, and tried accessing the VMware panel from my laptop, but no success.


So then:

  • The desktop CAN connect to the internet.
  • The desktop can communicate outwards to all other devices
  • No devices can communicate inwards to the desktop
  • Every now and then the desktop is unable to talk to other LAN devices(but it doesn't last long)
  • I have ran Malwarebytes and Avast
  • It is not the firewall
  • I have tried testing the device on another network to see if it's a problem with the router, and in the end is was not. It's definitely a problem with the desktop

Thanks in advance

share|improve this question
   
Hm.. I first thought you have "AP isolation" enabled on your router, but you claim desktop->other devices works. Do you have a reasonable test e.g. for laptop -> desktop? It requires some network service running, not hindered by the machine's firewall.– mvwJan 13 at 15:34
   
I've been trying to communicate from Phone/Laptop -> Desktop by attempting to connect on VMWare horizion, VMWare workstation, pinging it, and heading to its IP looking for a Unauthorised response, but I just get Your request timed out– Brendan JenningsJan 13 at 16:01
1 
Is that a good test? I you want to reach a service running within the VMware, this is more complicated (bridging, natd and so on) than having some other service, like a http server, directly running on the machine. It could be as simple as ruby -run -e httpd -- -p 5000 . or python3 -m http.server 8082 .– mvwJan 13 at 17:00
   
I'm not speaking about VMWare, I just meant I used that to test if I could connect or not. I'll start a http server now to test. But when I went ahead and put the IP in my browser I didn't get the denied response, I just got a time-out.– Brendan JenningsJan 13 at 19:05
   
Still no response with the http server running– Brendan Jennings2 days ago

I have managed to solve the issue, as I said it was a software issue.

Sadly it was a problem with avast, after repairing it - it now works fine. This was as avast kept freezing up and crashing (and its never happened before). I would like to thank mvw for his help as well!

share|improve this answer
   
Glad you got it working.– mvwyesterday
   
Thanks for your help, in the end it was avast. It kept freezing up then randomly changed all networks to public networks and got really defensive.– Brendan Jenningsyesterday
   
Never had an issue with avast in the years I've used it. Going to use glasswire for my firewall from now on (I bought a key for it a while ago but didn't really use it) So I might as well use my key and glasswire has more features for a firewall, including traffic monitoring!– Brendan Jenningsyesterday
   
Another lesson to keep an interfering anti malware on the list of culprits. They seem to dig deep into the operating system.– mvwyesterday

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.