I'm trying to have access to a server (I'm given a userID and the hots server) I'm trying to connect to it using the private key ( the public key was sent to them to set everything up). I added the private key in preferences of SFTP setting, and tried to connect with a Normal Log on type, but I get this error:

Command: Trust new Hostkey: OnceCommand: Pass: Error: Authentication failed.Error: Critical error: Could not connect to server

At first they told me that the private key doesn't match the public key we gave them, and I realized that Filezilla was actually using my id_rsa. I changed the setting and even changes id_rsa to the private key I needed for connecting to that SFTP, but I still get the same error.

Is there anything I need to do on my side, or it's all related to their side?

share|improve this question

closed as unclear what you're asking by Kamil Maciorowski, djsmiley2k, Scott, Pimp Juice IT, Simon Sheehan Jan 16 at 1:46

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

Server admins need to help you troubleshoot and clarify exactly what levels of communication are required for your account. Perhaps they've not loaded your public key into the SSH mailbox yet but hard telling but the server admins should be able to help troubleshoot, clarify, and confirm the specifics.– Pimp Juice ITJan 15 at 15:36
Since they said the private and public key doesn't match - then test exactly that first. Make sure you have the correct public and private key combination. Re send them the Public Key - and try login again.– DariusJan 16 at 22:55
I know which public key I sent them, so I'm using the corresponding private key. I just want to make sure Filezilla doesn't try to use my id_rsa in .ssh, but the private key I rpvide in SFTP settings.– may mJan 17 at 0:03