I hope someone can answer my issue. I'm running Kali Linux 4.14.0-kali-amd64 (latest) in VM VirualBox v5.1.30. Host machine is Windows 8.1 and my wireless usb adapter is Panda Wireless N600 Dual Band. I have the Network setting in VM as Bridged Adapter to my internal wireless card and can successfully ping and execute airodump-ng wlan0 with results.

I never get an IP address for the Wlan0 interface either in ifconfig -a or by running the route -n command and can't figure out why. I can tell you that I have an all-in-one modem/router unit, not sure if that would be an issue. Ive posted in text below and x'ed out the mac addresses. Thanks in advance to anyone who can assist.

root@kali2017:~# ifconfig -aeth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500inet 10.0.0.59 netmask 255.255.255.0 broadcast 10.0.0.255inet6 xxxxxxxxxxxxxxxxxx prefixlen 64 scopeid 0x0<global>inet6 xxxxxxxxxxxxxx prefixlen 64 scopeid 0x20<link>inet6 2601:201:1:4ee0:91d3:4b88:75d3:8e77 prefixlen 64 scopeid 0x0<global>ether xxxxxxxxxxxxxxx txqueuelen 1000 (Ethernet)RX packets 58 bytes 8752 (8.5 KiB)RX errors 0 dropped 0 overruns 0 frame 0TX packets 60 bytes 5399 (5.2 KiB)TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536inet 127.0.0.1 netmask 255.0.0.0inet6 ::1 prefixlen 128 scopeid 0x10<host>loop txqueuelen 1000 (Local Loopback)RX packets 24 bytes 1432 (1.3 KiB)RX errors 0 dropped 0 overruns 0 frame 0TX packets 24 bytes 1432 (1.3 KiB)TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0wlan0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500ether aa:d4:12:6e:e1:45 txqueuelen 1000 (Ethernet)RX packets 0 bytes 0 (0.0 B)RX errors 0 dropped 0 overruns 0 frame 0TX packets 0 bytes 0 (0.0 B)TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0root@kali2017:~# route -nKernel IP routing tableDestination Gateway Genmask Flags Metric Ref UseIface0.0.0.0 10.0.0.1 0.0.0.0 UG 100 0 0 eth010.0.0.0 0.0.0.0 255.255.255.0 U 100 0 0 eth0
  • Thanks for the reply G-man. You want the screenshots as text instead? please advise and thanks.– Just learningJan 11 at 5:34
  • Why do you expect wlan0 should have an IP address? Did you try to connect to a wireless network with it?– Kamil MaciorowskiJan 11 at 6:27
  • I'm taking a course and the instructor who apparently has the same setup had his wireless lan appear in the routing table. I'm just trying to learn this stuff. thanks anyway.– Just learningJan 11 at 6:37
  1. Download the Virtual Box Extensions Pack from the downloads page and install it.

  2. Change your bridged adaptor to NAT since it might interfere with the actual USB wireless device.

  3. Add the USB wireless adaptor device(check virtual box machine settings) to your Kali Linux guest VM.

  4. Setup WiFi on your Kali Linux as usual.

  5. Check wlan0

    Your Answer

     
    discard

    By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

    Not the answer you're looking for? Browse other questions tagged or ask your own question.