I am following this document

http://kb.eclipseinc.com/kb/how-to-configure-iis-smtp-server-to-forward-emails-using-email-account/

and in places where it was talking about ports etc i used the information

Gmail SMTP server settings

  1. Gmail SMTP server name: smtp.gmail.com

  2. Gmail SMTP username: your Gmail address

  3. Gmail SMTP password: your password

  4. Gmail SMTP port: 465

I also enabled TLS

but mails sent just get stuck in queue

My Settings

SMTP_DeliverTabOutbound ConnectionsOutbound SecurityAdvanced DeliveryRelay Restricions

    Mails sent just get stuck in queue

    You need to use port 587 with TLS.

    • Gmail SMTP port (TLS): 587
    • Gmail SMTP port (SSL): 465

    Source What Are the Gmail SMTP Settings?


    I'm getting an error message that my app is not secure

    Someone just tried to sign in to your Google Account myaccount@gmail.com from an app that doesn't meet modern security standards.

    You need to change a setting on your Gmail account.

    • Login to Gmail

    • Go to "My account"

    • Select "Sign-in & security"

    • Scroll to the bottom of the page

    • Set "Allow less secure apps" to "ON"

    enter image description here

    Try to send your emails again.


    Allowing less secure apps to access your account

    Google may block sign-in attempts from some apps or devices that donot use modern security standards. Since these apps and devices areeasier to break into, blocking them helps keep your account safe.

    Some examples of apps that do not support the latest securitystandards include:

    • The Mail app on your iPhone or iPad with iOS 6 or below
    • The Mail app on your Windows phone preceding the 8.1 release
    • Some Desktop mail clients like Microsoft Outlook and Mozilla Thunderbird

    Change account access for less secure apps

    To help keep Google Apps users' accounts secure, we may block lesssecure apps from accessing Google Apps accounts. As a Google Appsuser, you will see a "Password incorrect" error when trying to signin. If this is the case, you have two options:

    • Option 1: Upgrade to a more secure app that uses the most up to date security measures. All Google products, like Gmail, use the latestsecurity measures.

    • Option 2: Change your settings to allow less secure apps to access your account. We don't recommend this option because it might make iteasier for someone to break into your account. If you want to allowaccess anyway, follow these steps:

      1. Go to the "Less secure apps" section in My Account.
      2. Next to "Access for less secure apps," select Turn on. (Note to Google Apps users: This setting is hidden if your administrator haslocked less secure app account access.)

    Source Allowing less secure apps to access your account

    • You are correct i was using the wrong port after changing to 587 i got one partial success saying google prevented the sign in attempt coz app doens't meet modern standards but then after that nothing– SeanCltJun 10 '16 at 21:50
    • @SeanClt What is the exact error message?– DavidPostillJun 10 '16 at 21:59
    • no error message email just sits on the queue– SeanCltJun 10 '16 at 22:09
    • @SeanClt So what is this "app doens't meet modern standards" then?– DavidPostillJun 10 '16 at 22:10
    • Message in the email : Someone just tried to sign in to your Google Account myaccount@gmail.com from an app that doesn't meet modern security standards.– SeanCltJun 10 '16 at 22:11

    Your Answer

     
    discard

    By posting your answer, you agree to the privacy policy and terms of service.

    Not the answer you're looking for? Browse other questions tagged or ask your own question.