I recently upgraded to Yosemite, but I'm not sure if this is a Yosemite-related bug.

My application folder (/Applications) does not open in finder (see screenshots)The spinner keep spinning in the bottom right corner.Also, when I "Get Info", it keeps calculating the size and never completes.Also, when I drag the Applications folder to the dock, nothing happens.

However, it works fine in Terminal:

$ cd /; ls -lhdrwxrwxr-x+ 129 root admin 4.3K Oct 17 03:14 Applications

When I go inside the Applications folder (in terminal), I can list all the files in it.Oddly enough, most of them are greyed out, and it only says "total 8" when I have way more than 8 apps.

$ cd /Applications; ls -lhtotal 8drwxr-xr-x 4 root wheel 136B Apr 23 2013 3Hub.appdrwxr-xr-x@ 4 myusername staff 136B May 20 13:02 Adium.appdrwxrwxr-x 5 root admin 170B Feb 7 2013 Adobedrwxrwxr-x@ 7 root admin 238B Feb 14 2013 Adobe Acrobat XI Prolrwxr-xr-x 1 root admin 92B Feb 14 2013 Adobe Application Manager -> /Applications/Utilities/Adobe Application Manager/CCM/Utilities/AdobeCreativeCloudClient.appdrwxrwxr-x@ 8 root admin 272B Feb 7 2013 Adobe Bridge CS6drwxr-xr-x@ 3 myusername staff 102B Jul 20 2012 Adobe Cleaner.appdrwxr-xr-x@ 3 myusername staff 102B Dec 12 2012 Adobe Download Assistant.appdrwxrwxr-x@ 6 root admin 204B Feb 7 2013 Adobe Extension Manager CS6drwxrwxr-x@ 13 root admin 442B Feb 7 2013 Adobe Illustrator CS6drwxrwxr-x@ 13 root admin 442B Feb 7 2013 Adobe Photoshop CS6drwxr-xr-x 3 root wheel 102B Feb 7 2013 Adobe Photoshop Lightroom 4.appdrwxr-xr-x@ 3 myusername admin 102B Oct 15 2012 Air Video Server.appdrwxr-x---@ 5 myusername staff 170B Dec 12 2013 Android Development Kitdrwxr-xr-x+ 3 root wheel 102B Jul 11 15:49 App Store.app

I can even open my apps in Terminal:

$ cd /Applications; open Notes.app

Mission Control works fine as well.

Does anyone know how I can see my Applications in Finder?I've tried the usual Disk Utility (verify/repair permissions) and even reinstalled a fresh copy of Mac OSX Yosemite (using recovery).

Note: I did mess around with ~/Library/Preferences immediately after installing Yosemite because of the background flashing bug (I deleted some plists files to fix that bug).

Any help would be appreciated, thanks!

MacBook Pro (Retina, Mid 2012), OS X Yosemite (10.10), upgrade from latest mavericks

  • Perhaps a corrupt .DS_Store file in /Applications? Could try deleting it to see if the issue remains.– ScotOct 18 '14 at 9:36
  • I've tried deleting it.– AlexOct 18 '14 at 18:55
  • Is this limited to your user account?– ScotOct 19 '14 at 8:52
  • @Scot nope, it's system wide.– AlexOct 19 '14 at 21:53
  • I've seen the Finder grow so laggy - sometimes a forced restart (of Finder) helps.– Zo219Mar 29 '15 at 21:25

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.