During last summer I installed a ubuntu server 14.04 and used PuTTY with ssh to access it. I saved the public and private key on a backup. Since then i installed a clean windows 10 on the pc i used to access the server (upgrading from win7 with formatting all hdd). And today I needed to access the ubuntu server again after several months of not accessing it by ssh. During this time it was daily used as a emailserver and working well.

Today I tried to connect with PuTTY, choosing the right IP and Portnumber. Setting the Auto-login username to **** (category: Connection>Data). And providing a private key file for authentication (category: connection>ssh>auth). But then this keeps happening:

Output of PuTTY after opening the connection: Using username "****". Server refudes our key

And a popup with title: "Putty Fatal Error" and message: "Disconnected: No supported authentication methods availible (server sent: publickey)".

I tried different usernames, creating a new private key file from the old one (doesnt make any sense i know), ssh1 instead of the ssh2 (protocol options). And at this point i think i need to connect the server to a monitor and keyboard. To upload a new public key and create a private key for PuTTY. But the server is not easy to access. So I'm hoping for a easier solution via PuTTY. Maybe there was a update in PuTTY? Currently i use Putty 0.66

I got it installed in the summer using this: https://vorkbaard.nl/using-putty-and-keyfiles-to-ssh-into-your-ubuntu-12-04-server/

    Your Answer


    By posting your answer, you agree to the privacy policy and terms of service.

    Browse other questions tagged or ask your own question.