Recent Questions - Super User © superuser.commost recent 30 from superuser.com2018-04-20T07:06:11Zhttp://superuser.com.xemphimonlines.com/feedshttp://www.creativecommons.org/licenses/by-sa/3.0/rdf http://superuser.com.xemphimonlines.com/q/13156080Is there any way to generate protobuf file dynamically by reading source code? © superuser.comNarendar Sidduhttp://superuser.com.xemphimonlines.com/users/4543202018-04-20T06:25:40Z2018-04-20T06:25:40Z<p>I have gone through protobuf links , after reading all what i understood is we need to create proto file manually to generate client and server code in specified language. But I have a requirement where i need to generate proto file dynamically(auto generated proto file) from c++/java/rust code. Please let me know if any possibilities are there. </p><p>Thanks in advance.</p>http://superuser.com.xemphimonlines.com/q/13156050Oracle VM box and Windows Machine Network issue © superuser.comSaurabhhttp://superuser.com.xemphimonlines.com/users/8969402018-04-20T06:03:42Z2018-04-20T06:03:42Z<p>I have Oracle Virtual box with Centos 7 Os image in Windows Machine. </p><p>My Windows Machine is restricted with someone of websites ( Example shopping, Games and Entertainment ) </p><p>I'm not able to access above category website from Windows machine. </p><p>But in VM Centos 7 OS which i have created through Virtual box ( iso images). </p><p>there i'm able to access all this website.</p><p>Ideally i believe i shouldn't access Above Category website ? </p><p>Any Idea How can i block all this Website in VM also ? </p>http://superuser.com.xemphimonlines.com/q/13156040Equivalent of unix command "type" in command prompt © superuser.comGaurav Singhalhttp://superuser.com.xemphimonlines.com/users/4568782018-04-20T06:00:17Z2018-04-20T06:00:17Z<p>In Unix or Linux, <code>type &lt;arguement&gt;</code> provides information about how <code>argument</code> would be interpreted if used as a command. Is there any equivalent in command prompt (or in power shell as well). </p><p>I have seen few web pages which provides unix equivalents of command prompt commands (examples <a href="https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/4/html/Step_by_Step_Guide/ap-doslinux.html" rel="nofollow noreferrer">here</a> and <a href="https://www.lemoda.net/windows/windows2unix/windows2unix.html" rel="nofollow noreferrer">here</a>). What is the most exhaustive list you have come across?</p>http://superuser.com.xemphimonlines.com/q/1315595-1When exporting the selection as PDF in Microsoft Visio, how can I remove the margins? © superuser.comFranck Dernoncourthttp://superuser.com.xemphimonlines.com/users/1164752018-04-20T04:51:37Z2018-04-20T04:51:37Z<p>I want to export the selection in Microsoft Visio.</p><p>To do so, when exporting as PDF, I select <code>Selection</code>:</p><p><a href="https://i.stack.imgur.com/l8iDZ.png" rel="nofollow noreferrer"><img src="https://i.stack.imgur.com/l8iDZ.png" alt="enter image description here"></a></p><p>After the export, the PDF has tons of white margin:</p><p><a href="https://i.stack.imgur.com/LTIwH.png" rel="nofollow noreferrer"><img src="https://i.stack.imgur.com/LTIwH.png" alt="enter image description here"></a></p><p>When exporting the selection as PDF in Microsoft Visio, how can I remove the margins?</p>http://superuser.com.xemphimonlines.com/q/13155921Error : 'javac' is not recognized as an internal or external command, © superuser.comAntony Naveenhttp://superuser.com.xemphimonlines.com/users/6951102018-04-20T04:20:06Z2018-04-20T04:49:36Z<p>java program is not running on my windows 10 pc.</p><pre><code>C:\Users\Antony&gt;set path=C:\Program Files (x86)\Java\jre1.8.0_171\binC:\Users\Antony&gt;cd DesktopC:\Users\Antony\Desktop&gt;javac helloworld.java'javac' is not recognized as an internal or external command,operable program or batch file.C:\Users\Antony\Desktop&gt;environment path=C:\Program Files (x86)\Java\jre1.8.0_171\bin</code></pre><p>C:\Users\</p><pre><code>java -versionjava version "1.8.0_171"Java(TM) SE Runtime Environment (build 1.8.0_171-b11)Java HotSpot(TM) Client VM (build 25.171-b11, mixed mode, sharing)</code></pre><p>still showing same error</p>http://superuser.com.xemphimonlines.com/q/13155910My laptop keeps randomly restarting; is it worth it to get my motherboard replaced? © superuser.comSoulweaverBaliniahttp://superuser.com.xemphimonlines.com/users/8939862018-04-20T04:17:58Z2018-04-20T05:16:12Z<p>I have a Lenovo Thinkpad X1 Yoga that I bought new two years ago.</p><p>Last week, I began to have a problem with frequent, unexplained restarts. I ran a hardware scan, which found nothing. I ran several malware scans with a few different programs, which didn't find anything either. I turned off automatic restart. I ran disk and system checks. I looked in the Event Log for possible causes, and found no errors or warnings that happened before every restart. I was unable to find any explanation, even after extensive online searches.</p><p>Possible causes of the problem: my charger broke a few weeks ago, so I started using one from a different Lenovo laptop we had in the house. I originally ordered a new one off of Amazon, but returned it after I discovered that it was not manufactured by Lenovo. This could have caused an issue with the battery, but I have had no charge problems.</p><p>I went to Geek Squad at Best Buy today and they said it was probably a motherboard problem. Is it worth it to get it replaced? I'm not under warranty (it expired a year ago) so I don't know if I should send it in to the manufacturer. (It also has other issues that I don't need fixed, like missing keys and a cracked LCD display.) I don't want to have to get another computer with worse specs for more than I could pay to get my current one fixed. My current system cost about $1200.</p><p>I'm a sophomore in college studying computer science; I need a good laptop for coursework, and I don't have the money to spare to buy a new one of comparable quality.</p><p>System Specs:</p><ul><li>OS: Microsoft Windows 10 Pro</li><li>Manufacturer: Lenovo</li><li>Model: 20FQ000QUS</li><li>Type: x64-based PC</li><li>SKU: LENOVO_MT_20FQ_BU_Think_FM_ThinkPad X1 Carbon 4th (I don't know why it thinks it's a Carbon, it says it's a Yoga on the screen)</li><li>Processor: Intel(R) Core(TM) i7-6500U CPU @ 2.50 GHz, 2592 Mhz, 2 Cores, 4 Logical Processors</li><li>RAM: 8 GB</li><li>SSD: 475.69 GB</li><li>Graphics: Intel(R) HD Graphics 520, w/ 1 GB of RAM</li></ul>http://superuser.com.xemphimonlines.com/q/13155890How can bash read the background colour of the Putty window it's running in? © superuser.comberndbauschhttp://superuser.com.xemphimonlines.com/users/8783732018-04-20T04:11:59Z2018-04-20T04:11:59Z<p>I use various background colours to differentiate between the systems to which I log on. It's tiring to type <code>set background=light</code> or <code>set background=dark</code> in my vi sessions, and let's not talk about badly adapted color-ls. </p><p>Yes I know how I can manually configure and disable colouring. But I think it should be automatic. The shell should be able to figure out the background colour and configure vi, ls and perhaps other tools accordingly. Is that possible?</p><p>Same for Gnome terminal, just in case it uses different escape sequences than Putty.</p>http://superuser.com.xemphimonlines.com/q/13155880Add keyboard shortcut in Microsoft Word to open context menu © superuser.comIsaac Corbreyhttp://superuser.com.xemphimonlines.com/users/7238572018-04-20T03:56:37Z2018-04-20T05:03:13Z<p>I've been using Visual Studio very frequently as of late, and I'm very used to pressing <code>ALT+ENTER</code> to bring up the Intellisense context menu. However, Intellisense is (unfortunately) not included with Microsoft Word, and I seemingly cannot stop pressing <code>ALT+ENTER</code> to bring up the menu when I misspell something - inserting a newline instead of being of any help. How can I bind <code>ALT+ENTER</code> to the context menu?</p>http://superuser.com.xemphimonlines.com/q/13155861How to search file on linux with like atribut? © superuser.comUchsunhttp://superuser.com.xemphimonlines.com/users/2842762018-04-20T03:48:19Z2018-04-20T04:30:01Z<p>I want to find and delete log file on linux Terminal.</p><p>Usually I use this</p><blockquote><p>find -name '*.log'</p></blockquote><p>after the File found, next use this script</p><blockquote><p>find -name '*.log' -type f -delete</p></blockquote><p>that script work for </p><blockquote><p>filename.log</p></blockquote><p>but now I want to find and delete file like this</p><pre><code>mysqld.log-20180208 mysqld.log-20180223 mysqld.log-20180310 mysqld.log-20180325 mysqld.log-20180409mysqld.log-20180123.xz mysqld.log-20180209 mysqld.log-20180224 mysqld.log-20180311 mysqld.log-20180326 mysqld.log-20180410mysqld.log-20180124.xz mysqld.log-20180210 mysqld.log-20180225 mysqld.log-20180312 mysqld.log-20180327 mysqld.log-20180411mysqld.log-20180125.xz mysqld.log-20180211 mysqld.log-20180226 mysqld.log-20180313</code></pre><p>How Can I find filename.log-12313</p><p>I want delete filename.log- with number only.</p><p>Can anyone fix this?</p><p>thanks.</p><p>Im very appreciate your answer.</p>http://superuser.com.xemphimonlines.com/q/13155851File/directory in the CentOS looks weird © superuser.comsadyhttp://superuser.com.xemphimonlines.com/users/8969202018-04-20T03:42:32Z2018-04-20T03:58:08Z<p>I am connected to CentOS server via PuTTY and I see a weird file/directory in one of the sub-directory which looks unreal. I am not sure how the file exists there and Its not related to our work. Can anyone tell me what does the file mean?</p><p>We have a cronjob that will check MD5 values of the files in the directories, which is now failing that is failing on this sub-directory and I assuming this file could be one of the reason. Please suggest.</p><p>I see this when I do <code>ls -l</code></p><p><img src="https://i.stack.imgur.com/cXexL.png" alt="console screenshot"></p>http://superuser.com.xemphimonlines.com/q/13155841Can not write in a cell in Libre Office Writer © superuser.comOᐯI SᕮᖇGIᑌhttp://superuser.com.xemphimonlines.com/users/8969172018-04-20T03:36:08Z2018-04-20T03:39:42Z<p>I can not write anything in the circled cell.I created the document in Libre Office, and I can write in any other row or cell beside this one. I tried to enlarge it but nothing.The mouse cursor just won't stay in it.What can I do?</p><p><img src="https://i.stack.imgur.com/DCOxt.jpg" alt="screen shot"></p>http://superuser.com.xemphimonlines.com/q/1315531-1How to connect computers to switch? © superuser.comKristen Ungurhttp://superuser.com.xemphimonlines.com/users/8968342018-04-19T21:03:34Z2018-04-20T06:29:28Z<p>Me and my teacher came up with a problem that shutting down over 14+ PC's, updating them one by one takes tons of time and annoying to do.</p><p>We have switches on the second floor, computer class at third floor with over 14+ PC's and 1 main PC that teacher works on.</p><p>How can I and teacher connect computers to switch without Ethernet cable? Our goal is to get them all connected to switch and then, for example... use the command "shutdown now" on main PC and all other computers in computer class, over 14+ PC's will be shut down immediately.</p><p>One tip: We cannot use Ethernet cable to connect computers piece by piece to switch ports because the distance is too great between two floors.</p>http://superuser.com.xemphimonlines.com/q/13155200nginx reverse proxy redirect returns incorrect URL © superuser.comscott8035http://superuser.com.xemphimonlines.com/users/726442018-04-19T19:43:56Z2018-04-20T06:20:26Z<p>I am setting up JIRA Software in a Docker container. JIRA is listening on 127.0.0.1:8080. I have my reverse proxy on <a href="https://hostname/jira" rel="nofollow noreferrer">https://hostname/jira</a> redirecting the traffic using this config:</p><pre><code>location /jira {proxy_set_header X-Forwarded-Proto $scheme;proxy_set_header X-Real-IP $remote_addr;proxy_set_header Host $host;proxy_set_header X-Forwarded-Host $host;proxy_set_header X-Forwarded-Server $host;proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;proxy_pass http://127.0.0.1:8080;proxy_redirect off;}</code></pre><p>The problem is that I get a 302 redirect loop. When I visit <a href="https://hostname/jira" rel="nofollow noreferrer">https://hostname/jira</a> I get redirected to <a href="https://hostname/jira/jira/secure/SetupMode!default.jspa" rel="nofollow noreferrer">https://hostname/jira/jira/secure/SetupMode!default.jspa</a> over and over again. That would be the correct URL except for the extra "/jira" fragment.</p>http://superuser.com.xemphimonlines.com/q/13155170Dual boot Windows 10 (on HDD/SSD) with Ubuntu 14.04.5LTS (on USB) - can't boot without USB inserted © superuser.commikefohttp://superuser.com.xemphimonlines.com/users/3644982018-04-19T19:37:17Z2018-04-20T04:12:34Z<p>On a Toshiba P35W-B3226 with Windows 10 installed to internal SSD, I have created a dual-boot Windows 10 / Ubuntu 14.04.5LTS machine with Ubuntu 14.04.5 installed on a 64 GB USB pendrive. I used Rufus to create an install USB device using the 14.04.5 Desktop ISO (since the Toshiba has no CD/DVD drive) and installed 14.04.5 successfully on the destination USB using the "Something Else" selection during the Ubuntu install, creating a primary partition on the destination USB drive to hold the bootable / executable Ubuntu O/S. However, I have encountered a couple of problems:</p><ol><li>Setting BIOS Boot Order ("Power ON-F2") to "HDD first"/"USB second" gives me the GNU GRUB v2.02 <strong>command</strong> prompt whether the USB with Ubuntu is inserted or not. <em>I expected it to just boot Windows 10</em>.</li><li>Setting BIOS Boot Order to "USB first" / "HDD second" with USB attached gives me a GRUB <strong>GUI</strong> menu with: Ubuntu, Advanced options for Ubuntu, Windows Boot Manager (on /dev/sda2), System Setup. This is the only way I can boot to Windows 10, <strong>i.e. USB attached, BIOS boot order "USB first"</strong>.</li></ol><p>My hope-slash-expectation was that to boot Windows 10, I would just change the BIOS boot order with "HDD first" (with no USB attached); for Ubuntu, "USB first" (with USB attached). GRUB appears to have a presence on my SSD now.</p><p>Is there a way that I can get my desired behavior?</p><p>As an alternative, once I get the GRUB command prompt ("HDD first", no USB attached configuration), is there a way I can tell it to boot Windows without the Ubuntu O/S USB attached?</p><p>GRUB "ls" yields: <code>(hd0) (hd0,msdos1) (hd1) (hd1,gpt6) (hd1, gpt5) (hd1, gpt4) (hd1, gpt3) (hd1, gpt2) (hd1, gpt1)</code></p><p>I looked through some superuser.com answers that were similar, but they didn't appear to be close enough to my configuration.</p>http://superuser.com.xemphimonlines.com/q/13154693Does dual booting split RAM between the two systems? © superuser.comDr. valeshttp://superuser.com.xemphimonlines.com/users/8967622018-04-19T16:13:58Z2018-04-20T05:55:44Z<p>I would like to install Kali Linux on my computer using dual booting. My computer has 8 GB of RAM. Will it be separated into 4 GB for Kali Linux OS and 4 GB for Windows?</p>http://superuser.com.xemphimonlines.com/q/131539325Automatically 'brute force' a few bytes to recover a corrupt file © superuser.comSbt19http://superuser.com.xemphimonlines.com/users/8966552018-04-19T10:14:04Z2018-04-20T05:53:30Z<p>Does anyone out there know of a way to brute force values at a particular offset in a file? It's 4 consecutive bytes which would need to be brute forced. I know the correct SHA-1 of the corrupt file. So, what I'd like to do is compare the complete file SHA-1, each time it changes the byte value.</p><p>I know the exact 4 bytes which were changed, because the file was given to me by a data recovery expert, as a recovery challenge. For those who are interested in knowing, the rar file has 4 bytes which were intentionally changed. I was told the offsets of the changed 4 bytes and the original SHA-1. The person said it's IMPOSSIBLE to recover the exact file in the archive once the 4 bytes were changed. Even if it was only a few bytes and you knew exactly where the corruption was located. Since it doesn't have a recovery record. I'm trying to see if there is a way for those particular 4 bytes to be filled in correctly so the file will decompress without error. The file size is around 5mb.</p><p><strong>Example</strong>:</p><p>I uploaded photos so it's more clearly defined of exactly what I'm looking to do. I believe someone can post them here for me with more rep.</p><p><a href="https://i.stack.imgur.com/tFcaZ.jpg" rel="nofollow noreferrer"><img src="https://i.stack.imgur.com/tFcaZ.jpg" alt="Screenshot One"></a></p><p><a href="https://i.stack.imgur.com/5GIF8.jpg" rel="nofollow noreferrer"><img src="https://i.stack.imgur.com/5GIF8.jpg" alt="Screenshot Two"></a></p><p>The example offset I'm focusing on is <code>0x78</code> where the first pic shows the value as <code>CA</code>I want the script to the take the value up by 1 so it becomes <code>CB</code> as shown in the second pic. I want it to keep increasing the value by <code>1</code> and then compare the whole file SHA-1 each time. Only making changes to those 4 bytes at the specified offset.</p><p>It will try <code>CAC5C58A</code> and compare the SHA-1. If doesn't match, then it will try <code>CBC5C58A</code>.Then once the first value reaches <code>FF</code> it will then go to <code>00C6C58A</code> and so on. Basically, I would like it to be able to go from <code>00000000-FFFFFFFF</code> but to also have the option to choose where you want it start and end. I know it could take some time but I would still like to try it. Keep in mind I know the exact offset of the bytes which are corrupt. I just need the correct values.</p><p>If you search on Google: "How to fix a corrupted file by brute force" There's a person that wrote a Linux program. However, it only works against the files included with the program. I'm looking for some way to use the same process with my file. Thanks in advance for any advice.</p>http://superuser.com.xemphimonlines.com/q/13153101Repeating batch script © superuser.comSteveMhttp://superuser.com.xemphimonlines.com/users/7703212018-04-19T05:07:10Z2018-04-20T04:06:40Z<p>Looking for help with 3 problems with the below batch script called "Options" - would appreciate help with any of them</p><p>The script is designed to give quick access to four options I use frequently:1 Creating a folder called "test" in C drive2 Opening internet explorer3 Opening a folder called "test" in C drive4 Opening Devices and printers screen</p><p><strong><em>Here are the three problems:</em></strong></p><ol><li>Repeating - I want to be able to choose an option, such as open internet explorer, and then have the script return to start so that another option can be chosen and so on, until the user actually closes the command screen. Currently, only one action can be taken, then the command screen closes after pause</li><li>Using options that haven't been chosen - at the moment, if you select option 4, that is the only one that activates. However, if you choose 1, all four actions take place in sequence</li><li>If I call this script from another batch file, can I still use the repeating option mentioned at (1) from within the other script?</li></ol><p><strong>Contents of Batch Script - Options.bat</strong></p><pre><code>::Provides 4 action options@ECHO OFFC:CD\CLS:MENUCLSECHO=============MENU NAME=============ECHO -------------------------------------ECHO 1. Create "test" folder C driveECHO 2. Open Internet ExplorerECHO 3. Open "test" folderECHO 4. Open Devices and printersECHO==========PRESS 'Q' TO QUIT==========ECHO.SET INPUT=SET /P INPUT=Please select a number:IF /I '%INPUT%'=='1' GOTO Selection1IF /I '%INPUT%'=='2' GOTO Selection2IF /I '%INPUT%'=='3' GOTO Selection3IF /I '%INPUT%'=='4' GOTO Selection4IF /I '%INPUT%'=='Q' GOTO QuitCLSECHO============INVALID INPUT============ECHO -------------------------------------ECHO Please select a number from the Mainecho Menu [1-4] or select 'Q' to quit.ECHO -------------------------------------ECHO======PRESS ANY KEY TO CONTINUE======PAUSE &gt; NULGOTO MENU:Selection1md c:\test:Selection2start iexplore:Selection3start c:\test:Selection4control printers:QuitPAUSE</code></pre>http://superuser.com.xemphimonlines.com/q/13152160Keyboard Shortcut for Sort by Date Modified © superuser.comAdam Mhttp://superuser.com.xemphimonlines.com/users/5767682018-04-18T19:34:26Z2018-04-20T05:23:56Z<p>Noob hereI'm using autohot key to sorty by date modified whenever im in file explorer.</p><p>Problem is that in some folders if the order of the columns is different my script doesn't work.</p><p>Does anyone know if there's a unique code for date modified?</p><p>Below is my script:</p><p>F2::Send !vo{Down 1}{Enter}</p>http://superuser.com.xemphimonlines.com/q/13137951How do you save the user name in RDP without the computer name? [on hold] © superuser.comWilliam Gallagherhttp://superuser.com.xemphimonlines.com/users/8946492018-04-13T14:51:49Z2018-04-20T05:32:26Z<p>I was looking for a way to save my credentials without the computer name being a part of the user name. For example, instead of the user name being saved as "COMPUTER-NAME\will", I would like it to be saved as just "will".</p>http://superuser.com.xemphimonlines.com/q/12773590How often will an unassociated STA scan the network? © superuser.comSam Karrhttp://superuser.com.xemphimonlines.com/users/8219712017-12-15T10:17:18Z2018-04-20T06:28:38Z<p>Consider an 802.11 STA that is currently unassociated. While unassociated, how often will it scan the network (passively or actively) to determine available APs?</p><p>There is enough information about the actual scanning time (time to complete each scan) but it's hard to find the frequency of these scans. That is to say, how long will the STA wait to scan again if an initial scan fails to identify any nearby APs? Is it standardized in 802.11 or is it implementation specific?</p><p>It is much appreciated if any information regarding this can be provided for each of the scanning methods - active and passive.</p>http://superuser.com.xemphimonlines.com/q/11442190How to I use excel to extrapolate data using VLOOKUP and a data from a sounding table? © superuser.comMatthew Burdsallhttp://superuser.com.xemphimonlines.com/users/6621912016-11-10T04:50:48Z2018-04-20T06:06:36Z<p>Hello Im a Marine Engineer and I'm looking to make my life a little easier and create an automatic sounding table in excel. </p><p>I've been able to use VLOOKUP to get data from a table that's not the issue I have to enter data into the other table and work out the numbers in between, so my question is how can I get the data from the physical book the an excel document without having to calculate 800 plus vales for one tank? </p><p>For Example:</p><pre><code>A. B.0 0.4840.01 0.02 0.03 0.04 0.05 0.781</code></pre><p>Row A is the sounding in Meters and row B is the quantity relative to the sounding in cubic meters.<br>Now to work out 0.02m you have to do: </p><ul><li><code>0.781 - 0.484=0.297</code> </li><li>then <code>0.297/5=0.0594</code> because of the amount of values </li><li>now <code>(0.0594 x 2)+0.484=0.6028</code> which is the quantity if there was 3cm in the tank. </li></ul><p>The problem comes when the tank is not square so the number 0.0594 becomes different in the next set of 5 e.g</p><pre><code>A. B.0.06 0.8470.07 0.08 0.09 0.1 1.091</code></pre><ul><li><code>1.091-0.847=0.244</code></li><li><code>0.244/5=0.0488</code></li></ul><p>This tank has a depth of 12m so that's approx 1200 calculations to get a full table in excel from a physical. </p><p>How can I get all these values quicker than working them all out or how can I input a value of 0.02 in one cell and get the answer 0.6028? </p>http://superuser.com.xemphimonlines.com/q/10221041Scrolling up in iTerm2 shows previous Vim sessions © superuser.comBen Lindsayhttp://superuser.com.xemphimonlines.com/users/5323532016-01-05T15:20:52Z2018-04-20T05:54:42Z<p>In iTerm2 (Version 2.1.4), when I scroll up to see previous commands, I'm seeing chunks of previous Vim sessions, which I don't want to see. Any idea why that would be happening and how to fix that?</p><p>As an example, here's some output after I typed a line of a file in Vim, then scrolled up. The top line is a remnant of the Vim session. (I have line numbers on in Vim, which is where the <code>1</code> comes from.)</p><pre><code> 1 I'm typing a line in Vim.Last login: Tue Jan 5 10:16:18 on ttys001imac:~$ vi test.txtimac:~$ cat test.txtI'm typing a line in Vim.imac:~$</code></pre><p>Sometimes much larger remnants are displayed. Any thoughts would be appreciated.</p>http://superuser.com.xemphimonlines.com/q/8614183Place iPhone call from PC desktop © superuser.comRich Chttp://superuser.com.xemphimonlines.com/users/3824022015-01-06T18:41:07Z2018-04-20T05:06:35Z<h3>My Current Setup</h3><p>I make a lot of phone calls every day. The phone numbers are in an online CRM. My cell phone (iPhone 4s) sits in a cradle at my desk. I have a blue tooth earpiece connected to the iPhone. Right now, I re-type phone numbers from the web page into my iPhone and press dial. In addition to the extra typing I occasionally make typos while entering the number.</p><h3>What I'm Looking For</h3><p>I'd like to click on the phone number in the browser and have it dial the number on the iPhone (through the cradle USB). I'm open to bluetooth alternatives as well.</p><h3>What I've Found</h3><p>There are a few apps out there (like <a href="http://www.myphonedesktop.com/" rel="nofollow noreferrer">myPhoneDesktop</a>) that integrate with the iPhone. Unfortunately they typically offer a proxy screen on your desktop where you dial the number and it calls on your cell phone. Nice, but I still end up typing numbers in all day. As a side note, most of these apps seem to require a connection to some online database to handle syncing. I don't really want an cloud account for syncing. I just want the 10 digit number to go over my USB.</p><p>I've found old posts around the Web of people asking for similar functionality but the general response was that the software did not exist.</p><ul><li><a href="http://forums.webosnation.com/palm-os-devices-apps/96690-dial-phone-via-treo-650-pc-possible.html" rel="nofollow noreferrer">http://forums.webosnation.com/palm-os-devices-apps/96690-dial-phone-via-treo-650-pc-possible.html</a></li><li><a href="https://discussions.apple.com/thread/2058361?start=0&amp;tstart=0" rel="nofollow noreferrer">https://discussions.apple.com/thread/2058361?start=0&amp;tstart=0</a></li><li><a href="http://forums.macrumors.com/showthread.php?t=356491" rel="nofollow noreferrer">http://forums.macrumors.com/showthread.php?t=356491</a></li></ul><p>There are solutions that will dial a phone using RS232 connection. I don't think any of these solutions fit my use case.</p><ul><li><a href="http://www.infonautics.ch/phonedial/" rel="nofollow noreferrer">http://www.infonautics.ch/phonedial/</a></li></ul><p>There were several related SU questions like <a href="http://superuser.com.xemphimonlines.com/questions/241048/a-way-to-call-someone-from-pc-via-a-cellphone">A way to call someone from PC via a cellphone</a> or <a href="http://superuser.com.xemphimonlines.com/questions/308926/how-can-i-call-from-my-pc">How can I call from my PC?</a>. However, I would prefer to use my iPhone and not an online service like Google Voice.</p><p>The closest thing I've found is <a href="http://pushdialer.com/" rel="nofollow noreferrer">PushDialer</a>. Unfortunately they do not have a Windows version yet.</p><p>Has anyone come across a seemless solution? This seems like it should be a really simple intuitive use case but my searches are coming up empty.</p><h3>Edit #1</h3><p>The CRM I'm using renders phone numbers using a hyperlink with the <a href="http://www.ietf.org/rfc/rfc2806.txt" rel="nofollow noreferrer">tel</a> protocol.</p>http://superuser.com.xemphimonlines.com/q/8526632using *.bdc files in GoldenDict © superuser.comliving beinghttp://superuser.com.xemphimonlines.com/users/1747322014-12-15T06:32:43Z2018-04-20T05:53:07Z<p>I use GoldenDict. it can read *.bgl files which are originally designed for Babylon dictionary, but cannot read *.bdc files which is also Babylon dictionary format. Is there any way to convert *.bdc files to *.bgl files to use in GoldenDict? </p>http://superuser.com.xemphimonlines.com/q/8397801Links SSL Error © superuser.comjerz4lunchhttp://superuser.com.xemphimonlines.com/users/3896162014-11-13T20:43:25Z2018-04-20T06:06:36Z<p>What version of links does the user called "bytepool" have that he's able to find this workaround? Refer to link below. </p><p><a href="http://superuser.com.xemphimonlines.com/questions/631885">How to tell `links` to ignore expired SSL certificate and proceed?</a></p><p>He writes "I quickly peeked into the code, and it seems that the relevant function is verify_cert in https.c. .... So as a quick fix for my problem I just built myself a custom version in which verify_cert always returns true, i.e. the cert check is just completely bypassed."</p><p><strong>Further edit by barlop</strong></p><p>Going to <a href="http://links.twibright.com/download.php" rel="nofollow noreferrer">http://links.twibright.com/download.php</a> and downloading and extracting <a href="http://links.twibright.com/download/links-2.8.tar.gz" rel="nofollow noreferrer">http://links.twibright.com/download/links-2.8.tar.gz</a> I see this is the contents of https.c I see no verify_cert function</p><pre><code>Here is the contents of https.c/* https.c* HTTPS protocol client implementation* (c) 2002 Mikulas Patocka* This file is a part of the Links program, released under GPL.* In addition, as a special exception, the copyright holders give* permission to link the code of portions of this program with the* OpenSSL library under certain conditions as described in each* individual source file, and distribute linked combinations* including the two.* You must obey the GNU General Public License in all respects* for all of the code used other than OpenSSL. If you modify* file(s) with this exception, you may extend this exception to your* version of the file(s), but you are not obligated to do so. If you* do not wish to do so, delete this exception statement from your* version. If you delete this exception statement from all source* files in the program, then also delete it here.*/#include "links.h"#ifndef PATH_MAX#define PATH_MAX 255#endif#ifdef HAVE_SSLstatic SSL_CTX *context=NULL;SSL *getSSL(void){if (!context) {const SSL_METHOD *m;unsigned char f_randfile[PATH_MAX];unsigned char *os_pool;unsigned os_pool_size;const unsigned char *f=(const unsigned char *)RAND_file_name(cast_char f_randfile, sizeof(f_randfile));if (f &amp;&amp; RAND_egd(cast_const_char f) &lt; 0) {/* Not an EGD, so read and write to it */if (RAND_load_file(cast_const_char f_randfile, -1))RAND_write_file(cast_const_char f_randfile);}os_seed_random(&amp;os_pool, &amp;os_pool_size);if (os_pool_size) RAND_add(os_pool, os_pool_size, os_pool_size);mem_free(os_pool);/* needed for systems without /dev/random, but obviously kills security. *//*{static unsigned char pool[32768];int i;int rs;struct timeval tv;EINTRLOOP(rs, gettimeofday(&amp;tv, NULL));for (i=0; i &lt; (int)sizeof pool; i++) pool[i]=random() ^ tv.tv_sec ^ tv.tv_usec;RAND_add(pool, sizeof pool, sizeof pool);}*/SSLeay_add_ssl_algorithms();m=SSLv23_client_method();if (!m) return NULL;context=SSL_CTX_new((void *)m);if (!context) return NULL;SSL_CTX_set_options(context, SSL_OP_ALL);SSL_CTX_set_default_verify_paths(context);}return (SSL_new(context));}void ssl_finish(void){if (context) SSL_CTX_free(context);}void https_func(struct connection *c){c-&gt;ssl=DUMMY;http_func(c);}#elsevoid https_func(struct connection *c){setcstate(c, S_NO_SSL);abort_connection(c);}#endif</code></pre>http://superuser.com.xemphimonlines.com/q/7997421Intel USB3 driver install fails © superuser.comJohn Rozzellhttp://superuser.com.xemphimonlines.com/users/3591412014-08-18T23:16:28Z2018-04-20T03:55:51Z<p>I've been trying to install the Intel USB 3.0 eXtensible Host Controller Driver (version 3.0.0.16 as supplied by the Asus web site) but it balks when it gets to the PCI bus. At this point the entire system freezes for about 30 seconds and then a generic message is returned saying the install failed and some devices were not installed. If I try to install the PCI bus driver manually via the Device Manager (updating from the stock Microsoft driver and pointing it to the directory where the Intel USB3 drivers reside) It fails saying "The parameter is incorrect". Something has occurred in this process though, because the Device Manager is now listing the driver as Intel, version 3.0.0.16. Rebooting at this stage causes a BSOD while loading windows, requiring a repair boot and System Restore to recover.</p><p>Searching the Intel web site for the same drivers (in case the Asus copy is corrupt) only returns drivers for Series 7 or Series 8 chipsets, with no specific mention of Series 9 (I have Z97).</p><p>Why am I trying to do this? All my chipset-controlled USB3 ports (including the motherboard headers) are only operating as USB2. I have two ports fed by an ASMedia controller and they seem OK, it's just the Intel ones. this means I can't get my Akasa card reader to work, as it uses the motherboard headers.</p><p>I've tried reinstalling the chipset drivers (also downloaded from the Asus web site) to no avail. Any attempt to dislodge the Microsoft driver in favour of the Intel one results in boot failure.</p><p>The motherboard is an Asus Z97-PRO(Wi-Fi ac). I'm sorry I can't provide any more technical information at present (working nights and my PC is about seventy miles away) but if you tell me what you need I'll be back in about twelve hours...</p><h1>UPDATE</h1><p>I have half an answer: I went into the BIOS and changed Intel xHCI Mode to Enabled instead of Smart Auto, and all my USB devices appear to be operating correctly now. The driver still fails to fully install though, failing at the PCI bus again (although without the freeze this time). <a href="https://i.stack.imgur.com/v8rXB.png" rel="nofollow noreferrer">Here's a screenshot of the error message</a>, for what it's worth.</p><p>At least now I know my motherboard is not faulty, and everything works. Partially installed drivers always worry me though, in case they cause problems further down the line...</p>http://superuser.com.xemphimonlines.com/q/6676622How can I include guidance text in Word? © superuser.comgf131072http://superuser.com.xemphimonlines.com/users/2683282013-10-31T04:54:49Z2018-04-20T04:06:35Z<p>We use several Word documents as templates and currently include 'guidance' text for the reader - in the form of grey, italic text - to provide guidance to the person completing the document.</p><p><img src="https://i.stack.imgur.com/8Uk6E.png" alt="Example"></p><p>Note how the grey+italic text is used to provide both guidance and example content</p><p>Problems with this approach include:</p><ul><li>People forgetting to delete all of this template/boilerplate text</li><li>People using the italic+grey formatting when inputting <em>real</em> information because they don't change the style</li></ul><p>We've considered including Reviewing comments as an alternative but this can be a pain and suffers from the first problem above.</p><p>I'm not sure a simple, elegant solution exists here but if there's something obvious I'm missing I'd love to hear about it.</p>http://superuser.com.xemphimonlines.com/q/6565764How to launch multiple instances of VM image in VirtualBox? © superuser.comamphibienthttp://superuser.com.xemphimonlines.com/users/1346102013-10-09T15:15:44Z2018-04-20T05:06:35Z<p>I would like to configure a machine image with all the bells and whistles and then be able to launch multiple instances of it in VirtualBox. However, it allows me to launch only a single instance of each VM. I tried cloning VMs (and selecting reinitialize MAC address) and launching the clones, however, the clone doesn't get an IP address. So the original has the following network configuration:</p><pre><code>&gt;ifconfigeth0 Link encap:Ethernet HWaddr 08:00:27:92:0a:ec inet addr:192.168.103.49 Bcast:192.168.255.255 Mask:255.255.0.0inet6 addr: fe80::a00:27ff:fe92:aec/64 Scope:LinkUP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1RX packets:5317 errors:0 dropped:0 overruns:0 frame:0TX packets:68 errors:0 dropped:0 overruns:0 carrier:0collisions:0 txqueuelen:1000 RX bytes:516671 (516.6 KB) TX bytes:10492 (10.4 KB)lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0inet6 addr: ::1/128 Scope:HostUP LOOPBACK RUNNING MTU:16436 Metric:1RX packets:4 errors:0 dropped:0 overruns:0 frame:0TX packets:4 errors:0 dropped:0 overruns:0 carrier:0collisions:0 txqueuelen:0 RX bytes:337 (337.0 B) TX bytes:337 (337.0 B)</code></pre><p>whereas the clone has no <code>eth0</code>, only <code>lo</code> and I cannot ssh into it.</p>http://superuser.com.xemphimonlines.com/q/6051160Cannot Access Web GUI after changing to Router mode DD-WRT © superuser.comseanthewebberhttp://superuser.com.xemphimonlines.com/users/1917382013-06-07T23:05:46Z2018-04-20T04:06:35Z<p>I have a wireless router running DD-WRT (the latest version) and I set it up to be a Repeater Bridge to function as a second router, which means I had to change the Local IP Address and change the router mode to "Router" from "AP" mode. After I did so all devices connected to this router network properly and connect to each other and the internet, but I cannot access the second router's Web GUI. As a matter of fact, all devices connected to the router point to the primary router (AP mode) as being the Gateway and Router, and I can access the primary router's Web GUI.</p><p>Any idea how to access the second router's Web GUI? Any ideas are appreciated.</p>http://superuser.com.xemphimonlines.com/q/69044How can I get a new browser session when opening a new tab or window on Firefox/Chrome? © superuser.comMercer Traiestehttp://superuser.com.xemphimonlines.com/users/382009-07-15T09:57:46Z2018-04-20T03:39:43Z<p>When opening new Internet Explorer window, a new browser session is issued. Therefore you can login with two different accounts on the same service (let's say <a href="http://en.wikipedia.org/wiki/Gmail">Gmail</a>). The same does not apply when opening a new tab in the same window in Internet&nbsp;Explorer.</p><p>How can I get a new browser session when opening a new tab or window on Firefox?</p><p>How about Google Chrome?</p>